Help Request / Black Knight - System 7

View previous topic View next topic Go down

Help Request / Black Knight - System 7

Post by RDM on Wed Jul 23, 2014 8:41 am

Good morning! A quick hello to all from Winnipeg.

Down to business, does anyone around here have a working Black Knight or any Williams System 7 game that would be willing to help me troubleshoot a really annoying problem?

I have what I THINK/HOPE is a working CPU/Driver board combo for Black Knight. The problem is, that during a game, the score will climb as normal, gameplay appears to be working fine and then all of a sudden, the active player's score jumps up by an increment of 1,000,000 points or 4,000,000 points. Neither of which are values possible using the regular game rules as far as I can tell.

I'm really looking for someone willing to try these boards in their working system. Although, I fully understand if it's way out of the comfort zone and if this gets lost Smile

Thanks for reading anyway.

RDM

Posts : 3
Join date : 2013-12-12

Back to top Go down

Re: Help Request / Black Knight - System 7

Post by prock on Wed Jul 23, 2014 9:23 am

Weird, almost sounds like a code problem but it's most definitely not. Have you tried re-seating the ROMs? Perhaps re-burning the ROMs might be an idea. Do you know what version you're running? L-4 is the newest.
avatar
prock

Posts : 720
Join date : 2012-06-30
Location : Winnipeg

Back to top Go down

Re: Help Request / Black Knight - System 7

Post by RDM on Wed Jul 23, 2014 9:48 am

That's the part that bugs me, originally I thought it was a problem with the switch matrix, but none of the reading I've done would suggest this is an obvious switch issue. At least, as far as I can tell anyway. I don't have a tonne of experience.

The roms are as confirmed working as they can be I think. I bought them newly burned not 3 or 4 months ago from Atill Entertainment and according to his site, he uses version L-4.


RDM

Posts : 3
Join date : 2013-12-12

Back to top Go down

Re: Help Request / Black Knight - System 7

Post by prock on Wed Jul 23, 2014 9:59 am

Yeah I'd struggle to find a reason how the switch matrix could cause odd scoring like that. I'm assuming you've went through all the switches using the switch test. I'm not familiar with the rules but I don't imagine there is some sort of shot that would give you that many points over and over. Games of that era generally don't do things like that so that rules out a errant switch trigger.

I'd still say it would be worth looking at those ROMs. Do you have the old ROMs still? If you do try swapping them back in and see how it works.
avatar
prock

Posts : 720
Join date : 2012-06-30
Location : Winnipeg

Back to top Go down

Re: Help Request / Black Knight - System 7

Post by RDM on Wed Jul 23, 2014 10:16 am

From a purely mechanical standpoint during the self test yes, the switches all work without issue.

I do have the old roms yeah. I've got 3 complete sets actually, unfortunately the original ones that came with the machine and the replacements bought to replacee them don't allow the boards to boot.

I hadn't yet nailed down which individual chips were busted and which actually worked from either of the two sets, but I suppose considering where I'm at along my troubleshooting rope that's looking like a better idea.

I'll give that a shot. But I'm not confident!


RDM

Posts : 3
Join date : 2013-12-12

Back to top Go down

Re: Help Request / Black Knight - System 7

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum