Problem with power to playfield!?

Page 1 of 2 1, 2  Next

View previous topic View next topic Go down

Problem with power to playfield!?

Post by ericg on Mon Nov 02, 2015 3:23 pm

I just did the lithium battery cell mod to my Hurricane (unsoldered the old 3 aa battery holder and put a lithium cell holder in it). I plugged it all in and turned the machine on and it worked! The settings saved when turned off and all was good in the world. Then I exited the settings menu and tried to start a game.. There seems to be no power to the playfield anymore. Nothing works, no lights, no solenoids nothing. not even the backbox lights.. I have no clue what happened, all I did was replace the battery with a cell holder which everyone reccomended online, I did it properly and I plugged in all connections to the board properly as I took pics and labelled. Also when I turn off the machine, all the lights flash and even the backbox motor that spins the hurricane disk spins a bit like a stutter. Can anyone help me.. did i fuck up my machine LOL.. I didn't do anything bad I dont think.. Any help is appreciated..
avatar
ericg

Posts : 122
Join date : 2015-09-15
Age : 20

Back to top Go down

Re: Problem with power to playfield!?

Post by Malibu-ss on Mon Nov 02, 2015 3:27 pm

check the main fuse in the cabinet
avatar
Malibu-ss
Admin

Posts : 1533
Join date : 2011-09-29
Location : Winnipeg

Back to top Go down

Re: Problem with power to playfield!?

Post by ericg on Mon Nov 02, 2015 3:28 pm

I asked my dad and he thought it was a fuse too. I will check it when I have time.. Where is the main fuse? Is it labelled? Sorry for the questions, its my first time actually working inside of these things lol
avatar
ericg

Posts : 122
Join date : 2015-09-15
Age : 20

Back to top Go down

Re: Problem with power to playfield!?

Post by Malibu-ss on Mon Nov 02, 2015 3:35 pm

according to the manual,it should be a 8 amp fuse.It should be located at the right front corner inside the cabinet I believe.
avatar
Malibu-ss
Admin

Posts : 1533
Join date : 2011-09-29
Location : Winnipeg

Back to top Go down

Re: Problem with power to playfield!?

Post by ericg on Mon Nov 02, 2015 3:39 pm

I took it out and it looks fine but I will check it with a multimeter.. I don't have one on me right now but I will tomorrow. Any other ideas what it might be other than the fuse?
avatar
ericg

Posts : 122
Join date : 2015-09-15
Age : 20

Back to top Go down

Re: Problem with power to playfield!?

Post by Grevier2 on Mon Nov 02, 2015 4:51 pm

ROUGH!!!! Its bad if you only have one machine too and it becomes inoperable.. Depressing for sure. I hope you get it working soon but I have no advice for you. Are you on pinside? There are threads there for repairs and its quite active. You can probably get some quick replys to give you some leads. Having a machine broken down is like this thick black ominous cloud hanging over you. Well for me at least. lol
avatar
Grevier2

Posts : 220
Join date : 2015-08-10
Age : 30
Location : Elmwood

Back to top Go down

Re: Problem with power to playfield!?

Post by ericg on Mon Nov 02, 2015 5:34 pm

I agree Brennan. Yeah I'm on pinside I will be posting this on there soon lol. It's terrible I really wanna play some pin LOL. I'm actually at polo right now with my girlfriend and going to play some TOM cause I can't play at home . Also thanks for the help Malibu, will be trying the fuse tomorrow
avatar
ericg

Posts : 122
Join date : 2015-09-15
Age : 20

Back to top Go down

Re: Problem with power to playfield!?

Post by Grevier2 on Mon Nov 02, 2015 5:40 pm

Just don't remove my high score or ill never get it back on there! Lol the machine is dirty but works great. Its the only TOM I have played. Both hocus pocus magnet saves work despite the post on pinball tracker. Plus they serve rum and coke down there! Lol!
avatar
Grevier2

Posts : 220
Join date : 2015-08-10
Age : 30
Location : Elmwood

Back to top Go down

Re: Problem with power to playfield!?

Post by ericg on Mon Nov 02, 2015 5:45 pm

I think your score is already off LOL.. I didn't see it when I was down there. Taking a break and shopping now but I will double check after when I go back down
avatar
ericg

Posts : 122
Join date : 2015-09-15
Age : 20

Back to top Go down

Re: Problem with power to playfield!?

Post by Grevier2 on Mon Nov 02, 2015 5:48 pm

Aww lousy! It was the second place score. I forget what it was but I wouldn't be shocked if it was gone. It would be BH. I don't think it was a great score. Me and a buddy played that machine fir 4 hours one night. I brought a roll of loonies just to play that one. It would be on my want list if it wasn't for the expensive price tag.
avatar
Grevier2

Posts : 220
Join date : 2015-08-10
Age : 30
Location : Elmwood

Back to top Go down

Re: Problem with power to playfield!?

Post by ericg on Mon Nov 02, 2015 8:39 pm

Yeah it got knocked off, what a shame. I saw it on there a couple weeks ago though. We need meet up to play some pin at some places soon! Either the TOM at polo or some funhouse/LW3/BR around your area!
avatar
ericg

Posts : 122
Join date : 2015-09-15
Age : 20

Back to top Go down

Re: Problem with power to playfield!?

Post by Grevier2 on Mon Nov 02, 2015 8:44 pm

Me and mike hit up the funhouse later after you left on Friday. Went for some late breakfast and played the funhouse. It was being very receptive and only stole 2 balls from us. We rocked the table (well for noobs like us) I got another score on the board too. The theater of magic is too outta the way for me. they need another pin in there to make it more worth while. Id still meet there too but the strip by my place is better when the Funhouse is working.
avatar
Grevier2

Posts : 220
Join date : 2015-08-10
Age : 30
Location : Elmwood

Back to top Go down

Re: Problem with power to playfield!?

Post by Freezie on Mon Nov 02, 2015 11:42 pm

A good place is also the pinball Ninja ( http://www.pinballninja.com/wp-login.php?redirect_to=/ ) pay a one time pay pal fee and you can watch him do all kinds of repairs , I have learned a ton from his videos , and has in the past helped me fix my machines .
avatar
Freezie

Posts : 293
Join date : 2013-04-21

Back to top Go down

Re: Problem with power to playfield!?

Post by ericg on Tue Nov 03, 2015 11:36 am

I will check that out thanks Freezie. Also its not a fuse problem I checked them all Malibu..
avatar
ericg

Posts : 122
Join date : 2015-09-15
Age : 20

Back to top Go down

Re: Problem with power to playfield!?

Post by Malibu-ss on Tue Nov 03, 2015 11:40 am

weird,the wall plug works right?
avatar
Malibu-ss
Admin

Posts : 1533
Join date : 2011-09-29
Location : Winnipeg

Back to top Go down

Re: Problem with power to playfield!?

Post by ericg on Tue Nov 03, 2015 11:42 am

Yes, the game actually turns on and everything. Display works and I can go into settings etc. I can even start a game but when I do the ball doesnt go into play (no power to the kicker) and no lights are on or anything.
avatar
ericg

Posts : 122
Join date : 2015-09-15
Age : 20

Back to top Go down

Re: Problem with power to playfield!?

Post by Malibu-ss on Tue Nov 03, 2015 11:57 am

did you plug all the connectors back in when you reinstalled the board?Sounds like you might have left some off?
avatar
Malibu-ss
Admin

Posts : 1533
Join date : 2011-09-29
Location : Winnipeg

Back to top Go down

Re: Problem with power to playfield!?

Post by ericg on Tue Nov 03, 2015 11:59 am

I labelled and took pictures before I took the board out, and I plugged everything back the way it was.. There were some empty slots for connectors on the board but that's the way it was before hand.
avatar
ericg

Posts : 122
Join date : 2015-09-15
Age : 20

Back to top Go down

Re: Problem with power to playfield!?

Post by ericg on Tue Nov 03, 2015 12:00 pm

And I don't see any connectors that are unplugged or hanging around
avatar
ericg

Posts : 122
Join date : 2015-09-15
Age : 20

Back to top Go down

Re: Problem with power to playfield!?

Post by prock on Tue Nov 03, 2015 12:16 pm

hmm.. interesting issue.. can you be more specific as to what exactly is not working? If you go into the tests menu can you run through all the tests and see what doesn't work? solenoids? switches? lights? GI? any specific message when you try to start the game? does it search for balls?
avatar
prock

Posts : 720
Join date : 2012-06-30
Location : Winnipeg

Back to top Go down

Re: Problem with power to playfield!?

Post by ericg on Tue Nov 03, 2015 12:52 pm

Nothing works.. Went thru tests and no solenoids, lights or anything at all works. all that works is my display and game itself like the credits will go through and i can start a game but other than that its dead.. It starts a game like normal but the ball doesnt get kicked to the shooter lane cause no power.. But I noticed that when I turn it off, its like a surge of power goes through and all the lights flash...
avatar
ericg

Posts : 122
Join date : 2015-09-15
Age : 20

Back to top Go down

Re: Problem with power to playfield!?

Post by prock on Tue Nov 03, 2015 12:56 pm

Gotta be something on the driver board. MPU sounds like it's okay. Is the ribbon cable between the MPU and driver board connected properly? Make sure it's not off by one pin which can happen.
avatar
prock

Posts : 720
Join date : 2012-06-30
Location : Winnipeg

Back to top Go down

Re: Problem with power to playfield!?

Post by ericg on Tue Nov 03, 2015 1:01 pm

PROCK YOUR A FUCKIN GENIUS... I love you man. I resat the ribbon cable that is on the driver board and it works.. I don't know how that one got loose but I guess it got bumped when removing the board? Thank you so much... I can't believe it's fixed . Thank you all!! Love this group!
avatar
ericg

Posts : 122
Join date : 2015-09-15
Age : 20

Back to top Go down

Re: Problem with power to playfield!?

Post by prock on Tue Nov 03, 2015 1:03 pm

Just happy to get another pinhead up and running Very Happy
avatar
prock

Posts : 720
Join date : 2012-06-30
Location : Winnipeg

Back to top Go down

Re: Problem with power to playfield!?

Post by ericg on Tue Nov 03, 2015 1:08 pm

I was ready to change all the fuses too LOL. This is great. I'm so happy now. I can't believe its running. I turned it on not expecting anything because I didn't feel like it did much but behold all the lights turned on..

I replaced the battery holder and my dad thought it was a bad idea because he didn't think putting a cell battery would work in place of the AAs. So when the lights and game didn't work that proved that I shouldn't have done it and he got mad and said I screwed it up by adding it LOL.

I'm glad my game won't ever leak and it's so easy to change batteries now. I'm kind of happy my game went down cause I learned a lot about the driver board and the fuses etc. I also got myself a new multimeter cause I lost my old one.. Thanks again Prock and everyone here!
avatar
ericg

Posts : 122
Join date : 2015-09-15
Age : 20

Back to top Go down

Re: Problem with power to playfield!?

Post by Sponsored content


Sponsored content


Back to top Go down

Page 1 of 2 1, 2  Next

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum